Cannot connect to workflow editor

This topic contains 1 reply, has 2 voices, and was last updated by  Rich Hims 2 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #21316

    David
    Participant

    When I try to connect to the workflow editor (microsoft.dynamics.AX.Framework.Workflw.WorkflowEditorHost.application (15.9 KB) from [Our system connection – removed for privacy]) I get the following error:

    “An error occurred while making the HTTP request to [Our system connection – removed for privacy] This could be due to the fact that the server certificate is not configured properly with HTTPS.SYS in the HTTPS case. This could also be caused by a mismatch of the security binding between the client and the server.”

    #21326

    Rich Hims
    Participant

    David,

    We raised this with Microsoft and were advised that there are a couple of registry keys that should be added to each client machine that needs to access the workflow editor. The PowerShell script below (run as admin) will create the necessary keys (I had to remove the -Force & -Confirm parameters to get it to run on one client machine, though they are documented), but I’m sure you can work out what needs creating if the script doesn’t work for you

    Set-ItemProperty -Path "HKLM:\SOFTWARE\Microsoft\.NETFramework\v4.0.30319" -Name "SchUseStrongCrypto" -Value 1 -Type dword
    Set-ItemProperty -Path "HKLM:\SOFTWARE\Wow6432Node\Microsoft\.NETFramework\v4.0.30319" -Name "SchUseStrongCrypto" -Value 1 -Type dword​

    I’ve also found that opening the workflow editor from Edge rather than Chrome can do the job: hope one of those two ides will help.

    • This reply was modified 2 months ago by  Rich Hims.
Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.

Skip to toolbar