Error while upgrading from AX 4.0 to AX 2012 R3

This topic contains 2 replies, has 3 voices, and was last updated by  Locus IT 1 year ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #20756

    Adrian Cohen
    Participant

    I am upgrading from AX 4.0 to AX 2012 R3. I am doing code upgrade checklist. I have completed the step
    “”Import AOD files into the baseline model store””. I am following steps given in the upgradation book and also the link(technet.microsoft.com/…/gg188981.aspx).

    When I click on the “”Export baseline element ID’s “” in checklist , it’s raised the below error :
    “”The baseline model store contains upgrade preprocessing code. Before you can export element IDs, you must either remove the layer containing the preprocessing code or recreate the baseline model store without it.””

    Please suggest how to resolve it or which step I am missing.

    #21055

    Locus IT
    Participant

    Hello Adrian,

    It seems you still have the preprocessing XPO that is causing the error. (same is being checked in \Classes\SysUpgradeExportIds\containsPreprocessingCode)
    You should be taking a backup of the USR layer before importing the pro processing XPO in AX4/2009. The same will be used in the code upgrade not the one after importing the pre processing XPO.

    Please refer this topic documentation for more details : https://msdynamics.net/forums/topic/installing-upgrade-framework-files-in-ax/

    #20761

    Robert
    Participant

    It seems the same is being checked in \Classes\SysUpgradeExportIds\containsPreprocessingCode. You should be taking a backup of the USR layer before importing the pro processing XPO in AX4/2009.

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.

Skip to toolbar