Steps for repairing incorrect model element IDs

This topic contains 1 reply, has 2 voices, and was last updated by  Locus IT 5 months, 4 weeks ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #20739

    Lee Min
    Participant

    What are the steps for repairing incorrect model element IDs when upgrading to Microsoft Dynamics AX 2012 R3 + CU10 or later from any previous version of Dynamics AX 2012 R2?

    #21026

    Locus IT
    Participant

    Hello Lee,

    Instructions for repairing incorrect model element IDs when upgrading to Microsoft Dynamics AX 2012 R3 + CU10 or later from any previous version of Dynamics AX 2012 R2.

    It requires the Model Store Upgrader tool that is available for download in KB 3118784.

    1. Stop the AOS.
    2. Back up your current model store database. (This database will be modified, and if any issues occur, you will need to restore the backup.)
    3. Download the ModelStoreUpgrader tool.
    4. Run the UpdateModelElementOriginIds command:
    ModelStoreUpgrader.exe UpdateModelElementOriginIds InputFilePath=DynamicsAX2012R3OriginIDs.txt ModelStoreServer=localhost ModelStoreDatabaseName=MicrosoftDynamicsAX_model
    5. If you have a “DMF Labels” model in the SYP layer, remove it:
    AxUtil.exe delete “/model:DMF Labels”
    6. Copy the slipstream version of Dynamics AX 2012 R3 Cumulative Update 10 (CU10) or later into the Dynamics AX 2012 R3 installation media.
    7. Run setup.exe and complete the Microsoft Dynamics AX 2012 R3 installation steps.
    8. Run the FixElementIds command:
    ModelStoreUpgrader.exe FixElementIds ModelStoreServer=localhost BaselineModelStoreDatabaseName=MicrosoftDynamicsAX_UpgradeR3Baseline ModelStoreDatabaseName=MicrosoftDynamicsAX_model
    9. Compile the application:
    AxBuild.exe xppcompileall
    10. Proceed with the upgrade process

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.

Skip to toolbar